Next: , Up: Preparation   [Contents][Index]


2.1 Prerequisites

There are two types of dependencies for Scute: compile-time dependencies and run-time dependencies. The compile-time dependencies only need to be fulfilled when Scute is compiled and installed. The run-time dependencies need to be fulfilled when Scute is used in an application.

Scute depends, in addition to the essential build utilities, on the following packages at build time:

libgpg-error

Scute uses the GnuPG 2.0 framework for error handling, so it depends on the GPG error library. The minimum version required is 1.14.

libassuan

Scute uses the GnuPG 2.0 framework for communication with the GPG Agent, so it depends on the Assuan library. The minimum version required is 2.0.0.

At run-time, in addition to the run-time versions of the above libraries, you also need the following packages installed and configured:

GnuPG

Scute uses the GnuPG 2.0 framework to access the OpenPGP card and for certificate management. The minimum version required is 2.0.0.

Pinentry

Pinentry is a dependency of GnuPG 2.0, so it also needs to be installed with it.

Firefox et al.

Firefox is the first application supported by Scute. In the future, other applications may be supported. The applications are not dependencies of Scute, but Scute can not be used stand-alone, so you can not experience it without an application.